photo of the dji mavic mini with a phone showing DJI Fly app not installed

DJI Fly App Requires a 64-bit OS

DJI’s latest drone, the Mavic Mini, is described as the “everyday fly cam” and “fly as you are”, and at the retail price of $400, I’d say that’s about right! However, beyond the basic stated compatibility requirements that a device must have iOS 10.0+ or Android 6.0+, what they don’t state is that the DJI …

DJI Fly App Requires a 64-bit OS Read More »